Implantation Bleeding or Lite/Late Period?

Jessica - posted on 01/13/2014 ( 3 moms have responded )

3

0

0

Pretty regular with a 28-29 day cycle. Was supposed to start my period on January 5th. Didn't start. Took 3 tests- all were negative. Began spotting on Friday, January 10th. Saturday was a little heavier than spotting- but not anything like my normal period. Spotting is now gone. I took a test this morning and it was negative. Could it be implantation bleeding if it is after my expected period? If so- when should I retest?

MOST HELPFUL POSTS

Chet - posted on 01/13/2014

2,093

0

587

It's possible that it was implantation bleeding, I think it can take as long as six or seven days to get a positive urine test after implantation. It takes time for the hCG to build in your blood, and then to be filtered and appear in your urine in great enough concentration to cause a positive. So if you had implantation bleeding on the 10th, you should be able to get a positive urine test by the 17th.

Or you could get a blood test. That should be accurate now.

3 Comments

View replies by

Brandi - posted on 03/16/2015

1

0

0

I had the same thing Sunday 3/15/15 I was spotting dull cramping headache backache nausea &&' periods are irregular AF was to start 3/13/15 but didn't I'm confuse AF usually heavier it's lighter and darker don't know weather it's implantation blood or just period

Jessica - posted on 01/13/2014

3

0

0

I guess I will just wait until the end of this week to retest! Have been having some cramping- very minimal with lower back pain. No other symptoms of early pregnancy though. This would be my first, so I am just trying to figure all of this out! Thank you for the response.

Join Circle of Moms

Sign up for Circle of Moms and be a part of this community! Membership is just one click away.

Join Circle of Moms