Late period

Kay - posted on 07/01/2013 ( 7 moms have responded )

9

1

0

After my 2 child I had the implant in, i bled nearly hole 2 years with it.at the beginning of June I had it taken out and went on pill, after taken all my yellow pills I should of has a period , I am now 5 days late for my period, I have cramps in my lower abdominal there just like very light period pains but still no period and iv done 3 test all say negative and iv done them in the morning! Can I be preg or is it something else

MOST HELPFUL POSTS

Michelle - posted on 07/01/2013

5,046

8

3249

I could be just your body trying to regulate itself after bleeding for so long on the previous BC.
We really don't know what is going on so if you're really worried then you should see your doctor.

7 Comments

View replies by

Jodi - posted on 07/01/2013

3,562

36

3907

Just take the pill, and then take a test in a few days, just in case. It will be fine.

Kay - posted on 07/01/2013

9

1

0

I ain't got the implant in now I had it out 4-5 weeks ago and went on pill straight away and this week should be period week! With my other two the tests showed up a day after my period was missed , I'm just worried coz Thursday due to take my pill again but dunno wether to or not

Jodi - posted on 07/01/2013

3,562

36

3907

You still could be. 5 days isn't that much. I was 7 days late before a test showed positive. Maybe you should wait a few more days and test again. Your bleeding could be implantation.

Kay - posted on 07/01/2013

9

1

0

Cramps are getting bit sharper now and am getting a brown stringy discharge I should come on shortly shouldn't I ?

Join Circle of Moms

Sign up for Circle of Moms and be a part of this community! Membership is just one click away.

Join Circle of Moms